meta-nicole: phosphor-ipmi-config: Set device id

This adds a dev_id.json with Nicole specific values and a systemd unit
which changes at the boot time the device ID in the dev_id.json to the
actual BMC position.

Tested: `ipmitool mc info` now shows the actual BMC position in the
        Device ID field.

(From meta-yadro rev: 8dcdb1ef8661b2f5624d75787bd4bcc4da8301d7)

Change-Id: Ia819ef4154ffe368ca9684662c248295060e0597
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
new file mode 100644
index 0000000..466f42f
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+inherit systemd
+
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
+SYSTEMD_SERVICE_${PN} = "${BPN}.service"
+SRC_URI_append = " \
+    file://${BPN}-set-device-id.sh \
+    file://${BPN}.service \
+"
+
+S = "${WORKDIR}"
+do_install_append() {
+    install -d ${D}${bindir} ${D}${systemd_system_unitdir}
+    install ${BPN}-set-device-id.sh ${D}${bindir}/
+    install -m 0644 ${BPN}.service ${D}${systemd_system_unitdir}/
+}
+
+FILES_${PN}_append = " \
+    ${bindir}/${BPN}-set-device-id.sh \
+"