| DESCRIPTION = "DNS toolkit for Python" |
| HOMEPAGE = "http://www.dnspython.org/" |
| LICENSE = "ISC" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34" |
| |
| SRC_URI[sha256sum] = "e8f0f9c23a7b7cb99ded64e6c3a6f3e701d78f50c55e002b839dea7225cff7cc" |
| |
| inherit pypi python_hatchling ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| python3-pytest \ |
| python3-unittest-automake-output \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |
| |
| DEPENDS += "\ |
| python3-wheel-native \ |
| python3-setuptools-scm-native \ |
| " |
| |
| RDEPENDS:${PN} += " \ |
| python3-crypt \ |
| python3-io \ |
| python3-math \ |
| python3-netclient \ |
| python3-numbers \ |
| python3-threading \ |
| " |