meta-google: dhcp-done: Add recipe
This will be picked up by the gbmc-bridge DHCP process in another
change.
Change-Id: Id80688d0d7a7872bca2eec70c31468a483f72feb
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-google/networking/dhcp-done_git.bb b/meta-google/recipes-google/networking/dhcp-done_git.bb
new file mode 100644
index 0000000..5732033
--- /dev/null
+++ b/meta-google/recipes-google/networking/dhcp-done_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Google DHCP completion daemon"
+DESCRIPTION = "Google DHCP completion daemon"
+GOOGLE_MISC_PROJ = "dhcp-done"
+
+require ../google-misc/google-misc.inc
+
+inherit systemd
+
+SYSTEMD_SERVICE:${PN} += "dhcp-done.service"
+
+DEPENDS += " \
+ sdeventplus \
+ stdplus \
+ "
+
+SRC_URI += "file://50-dhcp-done.rules"
+FILES:${PN} += "${sysconfdir}/nftables"
+do_install:append() {
+ nftables_dir=${D}${sysconfdir}/nftables
+ install -d -m0755 "$nftables_dir"
+ install -m0644 ${WORKDIR}/50-dhcp-done.rules $nftables_dir/
+}