meta-openembedded: subtree update:ea8604a0e3..d0748372d2
Adrian Bunk (1):
libnih: Remove
Alexander Kanavin (3):
sysprof: add a recipe from oe-core
sysprof: update to 3.34.1
sysprof: fix ARM builds
Andreas Müller (2):
evolution-data-server: remove pythonnative from inherit
fontforge: rework for python3
Diego Rondini (2):
cups-filters: use libexecdir and cleanup
cups-filters: upgrade 1.26.0 -> 1.26.2
Gianfranco Costamagna (2):
websocketpp: refresh clang patch
vboxguestdrivers: update to new version 6.1.2
Khem Raj (14):
sysprof: avoid namesapace conflict with glibc headers
jack: Use c++ compiler for programs which use c++ source files
iozone3: Do not define prototype for pread64()
libhugetlbfs: Fix missing file mode in create() API
rdma-core: Use overloadable attribute with clang
sysprof: Correct systemdunitdir location
opencv: Tend for the compiler --param option rename in gcc10
grpc: Link with libatomic on powerpc
ssiapi: Needs boost/ppc support
fluentbit: Fix build on powerpc
mozjs: extend --with-intl-api=build to ppc
mpv: Disable lua support on powerpc
packagegroup-meta-oe: Remove unbuildable recipes for ppc64le from rdeps
opensc: Upgrade to 0.20.0
Mingde (Matthew) Zeng (2):
byacc: upgrade 20191103 -> 20191125
keyutils: upgrade 1.6 -> 1.6.1
Peter Kjellerstedt (1):
gitpkgv.bbclass: Add support for extending the supported tag formats
S. Lockwood-Childs (1):
lcov: geninfo needs another perl module
Wang Mingyu (15):
python3-cheetah: upgrade 3.2.3 -> 3.2.4
python3-coverage: 4.4.2 -> 5.0.2
python3-keras-applications: upgrade 1.0.6 -> 1.0.8
python3-keras-preprocessing: upgrade 1.0.5 -> 1.1.0
python3-more-itertools: 7.2.0 -> 8.1.0
python3-multidict: 4.5.2 -> 4.7.4
python3-ordered-set: 3.0.1 -> 3.1.1
python3-pulsectl: upgrade 18.12.5 -> 20.1.2
python-cmd2: upgrade 0.9.22 -> 0.9.23
python-engineio: upgrade 3.11.1 -> 3.11.2
python-javaobj-py3: upgrade 0.3.0 -> 0.4.0.1
python-kconfiglib: upgrade 10.42.0 -> 13.7.0
python-packaging: 19.2 -> 20.0
python-periphery: 2.0.0 -> 2.0.1
python-pyrsistent: upgrade 0.15.5 -> 0.15.7
William A. Kennington III via Openembedded-devel (1):
cppzmq: bump to version 4.6.0
Yi Zhao (3):
crda: fix UDEV_RULE_DIR
open-vm-tools: fix build error with usrmerge feature
multipath-tools: fix libudevdir
Zang Ruochen (14):
dhcpcd: upgrade 8.1.1 -> 8.1.5
fio: upgrade 3.16 -> 3.17
libencode-perl: upgrade 3.01 -> 3.02
zabbix: modify service file
libmicrohttpd: upgrade 0.9.68 -> 0.9.69
libsass: upgrade 3.6.1 -> 3.6.3
pcsc-lite: upgrade 1.8.25 -> 1.8.26
python3-yarl: upgrade 1.3.0 -> 1.4.2
python3-wheel: upgrade 0.32.3 -> 0.33.6
python3-websockets: upgrade 8.0.2 -> 8.1
python-wcwidth: upgrade 0.1.7 -> 0.1.8
python-waitress: upgrade 1.4.1 -> 1.4.2
python-tqdm: upgrade 4.38.0 -> 4.41.1
python-supervisor: upgrade 4.0.2 -> 4.1.0
Change-Id: I2c394941fc3140bfeadcec3542cd72892fdcda6e
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pulsectl_20.1.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pulsectl_20.1.2.bb
new file mode 100644
index 0000000..7ac3aaf
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pulsectl_20.1.2.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Python (3.x and 2.x) high-level interface and ctypes-based bindings for PulseAudio (libpulse), mostly focused on mixer-like controls and introspection-related operations (as opposed to e.g. submitting sound samples to play, player-like client)."
+HOMEPAGE = "https://github.com/mk-fg/python-pulse-control"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f1d10048469ff90123263eb5e214061d"
+
+SRC_URI[md5sum] = "90d02204d65f684af2fd77a77d50ec01"
+SRC_URI[sha256sum] = "4a97a4f7fcd8dbe56380980e8c9519ff4e26552604776cbc7555e6a14ff0202f"
+
+RDEPENDS_${PN} += "pulseaudio"
+
+inherit pypi setuptools3