Add recipe for phosphor-user-manager

Removed the obmc-phosphor-user and put the new one

Also, removed the usage of PREFERRED_PROVIDER and replaced by
VIRTUAL_RUNTIME for this feature

Change-Id: I6f0825f8d51eecb9c666a95d9fd702a8ea8bb08b
Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index f7a0df0..50f9065 100644
--- a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -21,6 +21,7 @@
         ${PN}-debug-collector \
         ${PN}-settings \
         ${PN}-network \
+        ${PN}-user-mgmt \
         "
 
 SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
@@ -104,3 +105,8 @@
 RDEPENDS_${PN}-network = " \
         ${VIRTUAL-RUNTIME_obmc-network-manager} \
         "
+
+SUMMARY_${PN}-user-mgmt = "User management applications"
+RDEPENDS_${PN}-user-mgmt = " \
+        ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
+        "