meta-ampere:u-boot: Add GPIO configuration for DVT boards
Mt.Jade DVT hardware requires some GPIO setting so that the board can
work well. This commit updates platform init function in u-boot to set
required GPIO pins.
Tested:
1. Verify below GPIOs set as input in Linux:
- S0_I2C9_ALERT_L (GPIOM4)
- S1_I2C9_ALERT_L (GPIOM5)
- GPIO_BMC_VGA_FRONT_PRES_L (GPIOQ7)
- GPIO_BMC_EXT_HIGHTEMP_L
- GPIO_S0_VRHOT_L
- GPIO_S1_VRHOT_L
- GPIO_BMC_PCA9554_INT_L
2. verify below GPIOs set as output high in Linux
- GPIO_BMC_I2C6_RESET_L
- GPIO_BMC_JTAG_SRST_L
- GPIO_BMC_VR_PMBUS_SEL_L
- BMC_GPIOR2_EXT_HIGHTEMP_L
- BMC_VGA_SEL
Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com>
Signed-off-by: Chanh Nguyen <chanh@os.amperecomputing.com>
Change-Id: I8b76387ec05c546c34c89f6f5881da3b7955a805
diff --git a/meta-ampere/meta-jade/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-ampere/meta-jade/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
index 0febf92..5fbc69f 100644
--- a/meta-ampere/meta-jade/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
+++ b/meta-ampere/meta-jade/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
@@ -6,4 +6,5 @@
file://0003-aspeed-support-passing-system-reset-status-to-kernel.patch \
file://0004-aspeed-add-gpio-support.patch \
file://0005-aspeed-Enable-SPI-master-mode.patch \
+ file://0006-aspeed-support-Mt.Jade-platform-init.patch \
"