meta-openembedded: refresh thud: cca27b5ea7..6ef9657068

Update meta-openembedded to thud HEAD.

Alexander Kanavin (2):
      packagegroup-meta-oe: drop ptest packages that do not exist
      packagegroup-meta-oe: rename the group that contains ptest packages

Andrea Adami (4):
      klibc: fix build for mipsel and mips64el with security flags enabled
      waf-cross-answers: Add cross-answers-mips64el.txt
      kexec-tools-klibc: fix build for mipsel and mips64el
      samba: fix build on qemumips64 with musl

Andreas Müller (1):
      libgit2: Fix install for multilib

Armin Kuster (1):
      wireshark: update to 2.6.6

Craig McQueen (1):
      python3-multidict: Workaround for broken make clean

Eduardas Meile (1):
      toybox: fix to use "usrmerge" distro feature properly

Haiqing Bai (1):
      ptpd: fixed the issue of ptpd2 daemon takes 100% CPU

Hong Liu (1):
      wireshark: upgrade to 2.6.5

Hongxu Jia (1):
      python-pyparted/python3-pyparted: drop incorrect and redundant PV

Kai Kang (1):
      net-snmp: inherit ptest

Khem Raj (16):
      xscreensaver: Define consistent app-defaults dir
      a2jmidid: Define own do_configure
      bpftool: don't build under musl
      packagegroup-meta-oe: Remove arch specific packages as needed
      packagegroup-meta-oe: Remove packages which don't build for musl
      modemmanager: Fix build with clang
      klibc: Fix build with clang
      srecord: GPL-3.0 and LGPL-3.0 is correct license
      packagegroup-meta-oe: Exclude unbuildable packages on mips64
      packagegroup-meta-oe: Exclude android-tools breakpad on ppc
      packagegroup-meta-oe: Remove unbuildable packages on risc-v from rdep
      mpv: Disable lua on mips/aarch64
      luajit: Disable for mips n64/n32 hosts
      licenses: Add Arphic-Public-License text
      nmap: Fix build with clang8/musl/libc++
      mozjs: Fix symbol visibility with clang/libc++

Marc Ferland (1):
      networkmanager: fix QA issue when using modemmanager and ppp in PACKAGECONFIG

Martin Jansa (1):
      open-vm-tools: fix indentation and drop FILES_${PN}-dbg

Mingli Yu (1):
      vim: improve reproducibility

Niko Mauno (7):
      python-pygobject: Fix invalid install path
      python-pygobject: Drop redundant PYTHON* refs
      python-pygobject: Drop redundant dependencies
      python-pygobject: Only check for even upstream versions
      python-pygobject: Remove duplication in inherit
      python-pygobject: Fix style issue
      python-pygobject: Tune remove operation

Otavio Salvador (2):
      mozjs: Avoid use of X11 from host when X11 is disabled
      postgresql: Allow successful run of postgresql-setup

Primoz Fiser (1):
      sedutil: fix compile errors on big endian architectures

Scott Ellis (2):
      nmap: Fix typo in pcre PACKAGECONFIG
      nmap: Include additional FILES path for certs

leimaohui (2):
      mraa: To file do_package error in multilib.
      makedumpfile: Add aarch64 into COMPATIBLE_HOST.

thc (1):
      fix networkmanager apppend

Change-Id: I979f5ccefeec364f27df10888ae6258923a30659
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openembedded/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb b/meta-openembedded/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb
index c444fbf..348a039 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/python/python-pygobject_3.28.3.bb
@@ -4,17 +4,13 @@
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
 
-inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
+inherit gnomebase gobject-introspection distutils-base upstream-version-is-even
 
-PYTHON_BASEVERSION = "2.7"
-PYTHON_PN = "python"
+DEPENDS += "python glib-2.0"
 
-DEPENDS += "gnome-common-native python glib-2.0"
-
-SRCNAME="pygobject"
+SRCNAME = "pygobject"
 SRC_URI = " \
     http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
-    file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \
 "
 
 SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90"
@@ -24,12 +20,12 @@
 
 BBCLASSEXTEND = "native"
 
-EXTRA_OECONF = "--disable-cairo --with-python=${PYTHON}"
+EXTRA_OECONF = "--disable-cairo"
 
 RDEPENDS_${PN} += "python-setuptools"
 RDEPENDS_${PN}_class-native = ""
 
 do_install_append() {
     # Remove files that clash with python3-pygobject; their content is same
-    rm -rf ${D}${includedir}/pygobject-3.0//pygobject.h ${D}${libdir}/pkgconfig
+    rm -r ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig
 }