meta-google: gbmc-bridge: Workaround do_rm_work

Otherwise when using a posix shell it will fail with:
Step #1: | ERROR: Execution of '/workspace/ci_workspace/gbmc/build/tmp/work/armv7a-openbmc-linux-gnueabi/gbmc-bridge/1.0-r1/temp/run.do_rm_work.40349' failed with exit code 1:
Step #1: | grep: invalid max count
Step #1: | rm: invalid option -- 'b'
Step #1: | Try 'rm ./-bmc-gbmcbr.netdev' to remove the file '-bmc-gbmcbr.netdev'.
Step #1: | Try 'rm --help' for more information.
Step #1: | WARNING: exit code 1 from a shell command.

Change-Id: Ie846810b3c5e187d20c18f843ff8e4b0851ed5df
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index 329a8b0..bacb349 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -97,3 +97,10 @@
   install -d -m0755 ${D}${systemd_system_unitdir}
   install -m0755 ${WORKDIR}/gbmc-br-ensure-ra.service ${D}${systemd_system_unitdir}/
 }
+
+do_rm_work_prepend() {
+  # HACK: Work around broken do_rm_work not properly calling rm with `--`
+  # It doesn't like filenames that start with `-`
+  mkdir -p ${WORKDIR}/done
+  mv -- ${WORKDIR}/-* ${WORKDIR}/done
+}