pdbg: Update to v2.5-rc1
Major upstream change was the split out the access method from the
device-tree representation to enable backend agnostic system device
trees.
Other notable features:
- Swift support
- get/putmempba
(From meta-openpower rev: 7781319d72b706d900253bc1ca730b44d2ca11f7)
Change-Id: I94b4c36427632fa13ea4cf582b4fce22e433c54e
Signed-off-by: Joel Stanley <joel@jms.id.au>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_2.5-rc1.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_2.5-rc1.bb
new file mode 100644
index 0000000..42c65e6
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_2.5-rc1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "PowerPC FSI Debugger"
+DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI += "git://github.com/open-power/pdbg.git"
+SRCREV = "6ae2ba655ca5e24b403a33bf15dff7261d3e7052"
+
+DEPENDS += "dtc-native"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+BBCLASSEXTEND = "native"