smbios-mdr: Add cpuinfo-peci PACKAGECONFIG
Part of the functionality contained in the existing `cpuinfo` flag is
now split into a new flag `cpuinfo-peci`. The new flag is still
logically dependent on the existing one, but it gives finer control over
enabled features.
Remove all cpuinfo flags from default PACKAGECONFIG.
Update bbappend based on new defaults.
smbios-mdr: srcrev bump abdccd3af9..4e1cf09955
Jonathan Doman (1):
cpuinfoapp: Make PECI features optional
Change-Id: Ib9a1e634634f046b2ec6ff5629d4498bf0d5914b
Signed-off-by: Jonathan Doman <jonathan.doman@intel.com>
diff --git a/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb b/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
index f6cea89..77475c6 100644
--- a/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
+++ b/meta-phosphor/recipes-phosphor/smbios/smbios-mdr_git.bb
@@ -10,10 +10,10 @@
phosphor-dbus-interfaces \
phosphor-logging \
"
-SRCREV = "abdccd3af908c96a90b3e890a422a0022f471991"
-PACKAGECONFIG ?= "cpuinfo"
+SRCREV = "4e1cf09955a2f7d62156fa87822acbd8ad57196e"
PACKAGECONFIG[smbios-no-dimm] = "-Ddimm-dbus=disabled,-Ddimm-dbus=enabled"
-PACKAGECONFIG[cpuinfo] = "-Dcpuinfo=enabled,-Dcpuinfo=disabled,libpeci i2c-tools"
+PACKAGECONFIG[cpuinfo] = "-Dcpuinfo=enabled,-Dcpuinfo=disabled,i2c-tools"
+PACKAGECONFIG[cpuinfo-peci] = "-Dcpuinfo-peci=enabled,-Dcpuinfo-peci=disabled,libpeci"
PACKAGECONFIG[smbios-ipmi-blob] = "-Dsmbios-ipmi-blob=enabled,-Dsmbios-ipmi-blob=disabled,phosphor-ipmi-blobs"
PACKAGECONFIG[assoc-trim-path] = "-Dassoc-trim-path=enabled,-Dassoc-trim-path=disabled"
PV = "1.0+git${SRCPV}"