meta-palmetto: Fix issues found by HW CI

HW CI on Palmetto trigers two issues:
1. The case to verify occ active fails because it was using the last
   character of `cpux` for occ, e.g. cpu0 -> occ0.
   Palmetto had an incorrect inventory path of `cpu`, which results in
   `occu`, and it becomes an incorrect path, and the case gets a 404
   error while trying to get the OCC active state.
2. The case to get https://$bmc/ fails, it's expecting HTTP 200 OK
   resonse, but got a 401 error. This is because webui is not built into
   Palmetto, so there is no page, and bmcweb returns 401 for such case.

Fix the above cases.

Tested: Verify the HW CI succeeds on Palmetto:

    python3 -m robot -v OPENBMC_HOST:palmetto --argumentfile \
        test_lists/HW_CI --exclude Verify_Redfish_Host_PowerOn --include \
        Verify_Redfish_Host_PowerOn_No_Check_Watts  redfish  tests

(From meta-ibm rev: 4ac52cb28db30f89bdfd23ab1614f71b65dfdceb)

Signed-off-by: Lei YU <mine260309@gmail.com>
Change-Id: Ifd102f167cfa4d83769fb055b883e4c214a27b9a
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index c0748b9..52b9468 100644
--- a/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1 +1 @@
-RDEPENDS_${PN}-inventory_append_palmetto = " openpower-occ-control"
+RDEPENDS_${PN}-inventory_append_palmetto = " openpower-occ-control phosphor-webui"