meta-ibm/SBP1: Add LEDs

Configure phosphor-led-manager and run bmc_booted after network
is online and the LED services have started.

Tested: The led BMC_READY turns on and the leds ID_DWR turn off
        when the BMC finishes booting and is reachable over network.

Change-Id: Ib8d7cc994d9ecaffedb4935f7344a041930f6451
Signed-off-by: Patrick Rudolph <patrick.rudolph@9elements.com>
diff --git a/meta-ibm/meta-sbp1/recipes-phosphor/leds/sbp1-led-manager-config-native.bb b/meta-ibm/meta-sbp1/recipes-phosphor/leds/sbp1-led-manager-config-native.bb
new file mode 100644
index 0000000..997adf1
--- /dev/null
+++ b/meta-ibm/meta-sbp1/recipes-phosphor/leds/sbp1-led-manager-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor LED Group Management for SBP1"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml \
+           "
+S = "${WORKDIR}"
+
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
\ No newline at end of file