fb-ipmi-oem: srcrev bump f863a184bf..17bd2eabd1

Karthikeyan Pasupathi (1):
      yosemitev2: Multi-host information displayed in OCP debug-card

Patrick Williams (4):
      build: additional cmake/meson cleanups
      appcommands: handle system result for sled-cycle
      oemcommands: fix invalid string find result
      meson: adjust library build

Willy Tu (1):
      build: Convert project to meson and C++20

Switch recipe to Meson.

Change-Id: I17ea8a88d6b03ec8df3ec554a3a71ba3fe072943
Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
index c26b344..02e42aa 100755
--- a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
+++ b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
@@ -5,19 +5,17 @@
 LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
 
 SRC_URI = "git://github.com/openbmc/fb-ipmi-oem;branch=master;protocol=https"
-SRCREV = "f863a184bf53570e40e185859c9296c111309157"
+SRCREV = "17bd2eabd11366185ff6c23a0300302da9f87229"
 
 S = "${WORKDIR}/git"
 PV = "0.1+git${SRCPV}"
 
 DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd "
 
-inherit cmake pkgconfig obmc-phosphor-ipmiprovider-symlink
+inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
 
-EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
-EXTRA_OECMAKE:append:yosemitev2 = " -DBIC=1"
-
-EXTRA_OECMAKE:append = " -DHOST_INSTANCES='${OBMC_HOST_INSTANCES}'"
+EXTRA_OECMAKE="-Dtests=0 -Dbic=0 -Dhost-instances='${OBMC_HOST_INSTANCES}'"
+EXTRA_OECMAKE:remove:yosemitev2 = "-Dbic=0"
 
 LIBRARY_NAMES = "libzfboemcmds.so"