meta-phosphor: obmc-console: remove excess install for non-ssh
When the "ssh" `PACKAGECONFIG` is disabled, we should not install
some configuration related to SSH:
1. The `dropbear.env` file.
2. The Avahi / SLP registration for the client console SSH port.
Utilize PACKAGECONFIG accordingly.
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I3ebb09c9b09c239c259697d361a5fe8f0c8c0f11
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 00520db..09c133f 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -36,7 +36,9 @@
# Install the server configuration
install -m 0755 -d ${D}${sysconfdir}/${BPN}
- install -m 0644 ${WORKDIR}/dropbear.env ${D}${sysconfdir}/${BPN}/
+ if ${@bb.utils.contains('PACKAGECONFIG', 'ssh', 'true', 'false', d)} ; then
+ install -m 0644 ${WORKDIR}/dropbear.env ${D}${sysconfdir}/${BPN}/
+ fi
# If the OBMC_CONSOLE_TTYS variable is used without the default OBMC_CONSOLE_HOST_TTY
# the port specific config file should be provided. If it is just OBMC_CONSOLE_HOST_TTY,
@@ -80,7 +82,7 @@
TARGET_CFLAGS += "-fpic -O2"
-REGISTERED_SERVICES:${PN} += "obmc_console:tcp:2200:"
+REGISTERED_SERVICES:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'ssh', 'obmc_console:tcp:2200:', '', d)}"
OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
# Support multiple TTY ports using space separated list.
# Ex. OBMC_CONSOLE_TTYS = "ttyS1 ttyS2"