meta-ibm: genesis3: Add entity-manager config
- Add blacklist for I2C buses that have no FRU devices.
- Default to dbus-sensors.
Tested: All configured sensors are visible in the webui.
Change-Id: Ia08f473775eac836e01ab7cc9a7e0eaf56d99192
Signed-off-by: Patrick Rudolph <patrick.rudolph@9elements.com>
diff --git a/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager_%.bbappend
new file mode 100644
index 0000000..62e1499
--- /dev/null
+++ b/meta-ibm/meta-genesis3/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append = " file://blacklist.json"
+
+do_install:append () {
+ install -m 0644 -D ${WORKDIR}/blacklist.json ${D}${datadir}/${PN}/blacklist.json
+}