meta-openembedded: subtree update:55de2d06ad..53d431639a
Adrian Bunk (1):
ltrace: Remove RDEPENDS on elfutils
Andreas Müller (22):
gedit: upgrade 2.30.4 -> 3.34.0
gtksourceview2: remove
evolution-data-server: give up fine grained -dev/-dbg packages
evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework
gnome-font-viewer: initial add 3.34.0
evince: upgrade 3.28.2 -> 3.34.1
file-roller: inital add 3.32.2
gexiv2: initial add 0.12.0
gnome-autoar: inital add 0.2.3
tracker: initial add 2.3.1
nautilus: upgrade 3.18.5 -> 3.34.1
geocode-glib: initial add 3.26.1
libgweather: initial add 3.34.0
libwacom: initial add 0.33
gnome-settings-daemon: initial add 3.34.1
fluidsynth: upgrade 2.0.7 -> 2.0.9
gnome-terminal: re-add 3.34.2
gnome-terminal: Fix build for musl
gmime: cleanup recipe
gmime: move to meta-oe/recipes-gnome
gmime: upgrade 3.2.4 -> 3.2.5
evolution-data-server: add upstream-version-is-even & gsettings to inherit
Bartosz Golaszewski (1):
libgpiod: put gpio utils into an actual separate package
Gaylord Charles (1):
nginx: fix install paths
Khem Raj (11):
evince: Fix build with clang
poppler: Extend the c/c++ flags fix to cover clang
pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t
gperftools: Convert static and libunwind support to packageconfig
libmad: Define O2 for all arches as default optimization
rsyslog: Dont force enable atomic builtins on mips
libtorrent: Drop 64bit atomics patch for mips/ppc
libtorrent: Disable instrumentation on ppc/mips
libkcapi: Move static inline functions where used
grpc: Link with libatomic on clang/x86
upm: Link with libatomic on clang/x86
Leon Anavi (1):
surf: Add a simple web browser
Martin Balik (1):
squid: upgrade 4.6 -> 4.9
Nicola Lunghi (2):
python-jsonschema: multiple fixes
python-jsonschema: add PACKAGECONFIG nongpl option
Oleksandr Kravchuk (1):
flatbuffers: update to 1.11.0
Peter Kjellerstedt (1):
libldb: Do not require the "pam" distro feature to be enabled
nick83ola (2):
python3-apply-defaults: add recipe
python3-jsonrpcserver: add recipe
Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.0.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.0.5.bb
new file mode 100644
index 0000000..bf9eb0a
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.0.5.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Library to process JSON-RPC requests"
+HOMEPAGE = "https://github.com/bcb/jsonrpcserver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c89120516900f96f4c60d35fdc4c3f15"
+
+SRC_URI[md5sum] = "d41e9f6b310cb29b0d8f213ff9d57567"
+SRC_URI[sha256sum] = "240c517f49b0fdd3bfa428c9a7cc581126a0c43eca60d29762da124017d9d9f4"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-apply-defaults \
+ python3-asyncio \
+ python3-core \
+ python3-json \
+ python3-jsonschema \
+ python3-logging \
+ python3-netclient \
+ python3-pkgutil \
+ python3-typing \
+"
+
+BBCLASSEXTEND = "native nativesdk"
\ No newline at end of file