meta-amd: fix compilation errors with latest Yocto
Make the following changes to fix compilation errors:
- add honister to the LAYERSERIES_COMPAT variable,
- increase CONF_VERSION to 2,
- use new bitbake override syntax
Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Change-Id: I971f0f0f7110e0350994ced151ca429444885056
diff --git a/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
index 9ae1d42..1f2e6c0 100644
--- a/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
+++ b/meta-amd/recipes-phosphor/logging/phosphor-hostlogger_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
# Default service instance to install (single-host mode)
DEFAULT_INSTANCE = "ttyS0"
-SRC_URI_remove = "file://${BPN}.conf"
+SRC_URI:remove = "file://${BPN}.conf"
SRC_URI += "file://ttyS0.conf"