Don't inherit image-overlay by default
This attempts to address a race condition in the build where
we attempt to build a complete flash image before all the sub-images
are available (specifically the initramfs image).
Any classes in IMAGE_CLASSES are inherited by all image recipes, including
the initramfs image. OE-Core's live/hddimg recipes address this
by pulling in the class configuration in recipe scope, rather than
global scope. Copy that behavior here.
diff --git a/meta-phosphor/classes/image-overlay.bbclass b/meta-phosphor/classes/image-overlay.bbclass
index 8997aae..71768a6 100644
--- a/meta-phosphor/classes/image-overlay.bbclass
+++ b/meta-phosphor/classes/image-overlay.bbclass
@@ -1,3 +1,5 @@
+PACKAGES = " "
+EXCLUDE_FROM_WORLD = "1"
INITRD_IMAGE ?= "core-image-minimal-initramfs"
INITRD ?= "${DEPLOY_DIR_IMAGE}/${INITRD_IMAGE}-${MACHINE}.cpio.${INITRD_CTYPE}${uboot}"
@@ -5,9 +7,9 @@
IMAGE_BASETYPE ?= "squashfs-xz"
OVERLAY_BASETYPE ?= "jffs2"
-IMAGE_TYPES_${PN} += "${IMAGE_BASETYPE}"
+IMAGE_TYPES += "overlay"
-IMAGE_TYPEDEP_overlay = "${IMAGE_BASETYPE} ${OVERLAY_BASETYPE}"
+IMAGE_TYPEDEP_overlay = "${IMAGE_BASETYPE}"
IMAGE_TYPES_MASKED += "overlay"
ROOTFS ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_BASENAME}-${MACHINE}.${IMAGE_BASETYPE}"
@@ -15,4 +17,4 @@
do_generate_flash[depends] += "${INITRD_IMAGE}:do_rootfs"
do_generate_flash[depends] += "${PN}:do_rootfs"
-addtask generate_flash after do_rootfs before do_build
+addtask generate_flash before do_build