meta-openembedded: refresh master: 0435c9e193..4a9deabbc8
Update meta-openembedded to master HEAD.
Alistair Francis (7):
python3-pyaudio: Initial commit
python3-pyfann2: Initial commit
python3-pocketsphinx: Initial commit
python3-xxhash: Initial commit
mycroft: Initial commit
libfann: Initial commit
python-cryptography: Bump from 2.4.1 to 2.6.1
Andreas Müller (10):
xfce4-screenshooter: upgrade 1.9.4 -> 1.9.5
networkmanager: Fix upstream regex for 1.16
networkmanager: fix build with musl
gvfs: fix configure options and DDEPENDS
rrdtool: fix build by disabling docs
libpeas: rework gobject-introspection handling
gvfs: Fix missing executable permission flags for files in libexec
gnome-desktop3: remove gconf from DEPENDS
gnome-desktop3: rework gobject-introspection handling
gnome-desktop3: Disable libseccomp for all archs
Brad Bishop (1):
libvncserver: enable split client/server packages
Fabio Berton (1):
python*-requests: Update 2.20.1 -> 2.21.0
Gianfranco Costamagna (2):
cpprest: fix build failure on 32bit systems, with upstream merged patch
libmodbus: start to prefer version 3.1.4 as default
Hongxu Jia (1):
dracut: fix udevdir not found
Khem Raj (5):
ncmpc: Rename artist_screen to library_screen
networkmanager: Fix build with clang
alsa-oss: Upgrade to 1.1.8
redis: Fix ocasional parallel build failure
lcdproc: Fix parallel build
Nikolay Nizov (2):
android-tools-conf: fix typo
android-tools-conf: Make sure /dev/pts/0 exists
Oleksandr Kravchuk (2):
fping: update to 4.2
nuttcp: update to 7.3.3
Peter Kjellerstedt (1):
doxygen: Make it build with ninja 1.9.0
Qi.Chen@windriver.com (2):
openldap: add missing CVE tag to patch
ipsec-tools: add missing CVE tags to patches
Randy MacLeod (2):
imagemagic: upgrade to 7.0.8-35
wolfssl: update to 3.15.8 and use github SRC_URI
Slater, Joseph (1):
tcpreplay: update to version 4.3.2
Vincent Prince (4):
Rsyslog: Add mmjsonparse to PACKAGECONFIG
zeromq: bump version 4.2.5 => 4.3.1
cppzmq: bump version 4.2.3 => 4.3.0
czmq: bump version 4.1.1 => 4.2.0
Yi Zhao (3):
python-engineio: add recipe
python-socketio: add recipe
python-flask-socketio
Zang Ruochen (4):
augeas: upgrade 1.10.1 -> 1.11.0
libedit: upgrade 20181209-3.1 -> 20190324-3.1
mcelog: upgrade 161 -> 162
lockfile-progs: upgrade 0.1.17 -> 0.1.18
leimaohui (1):
Fix build error for armeb.
Change-Id: Ie79748c484bcf4fd28b3bde84e2194044e1c08a8
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/zeromq/czmq_4.2.0.bb b/meta-openembedded/meta-oe/recipes-connectivity/zeromq/czmq_4.2.0.bb
new file mode 100644
index 0000000..4ec1c04
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/zeromq/czmq_4.2.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "High-level C binding for 0MQ"
+HOMEPAGE = "http://czmq.zeromq.org/"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+DEPENDS = "zeromq"
+
+SRC_URI = "https://github.com/zeromq/czmq/releases/download/v${PV}/czmq-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "7e09997db6ac3b25e8ed104053040722"
+SRC_URI[sha256sum] = "cfab29c2b3cc8a845749758a51e1dd5f5160c1ef57e2a41ea96e4c2dcc8feceb"
+
+inherit cmake
+
+PACKAGES = "lib${BPN} lib${BPN}-dev lib${BPN}-staticdev ${PN} ${PN}-dbg"
+
+FILES_${PN} = "${bindir}/*"
+FILES_lib${BPN} = "${libdir}/*.so.*"
+FILES_lib${BPN}-dev = "${libdir}/*.so ${libdir}/pkgconfig ${includedir} ${datadir}/cmake"
+FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
+
+RDEPENDS_lib${BPN}-dev = "zeromq-dev"
+
+PACKAGECONFIG ??= "lz4 uuid curl ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[lz4] = ",-DCMAKE_DISABLE_FIND_PACKAGE_lz4=TRUE,lz4"
+PACKAGECONFIG[uuid] = ",-DCMAKE_DISABLE_FIND_PACKAGE_uuid=TRUE,util-linux"
+PACKAGECONFIG[curl] = ",-DCMAKE_DISABLE_FIND_PACKAGE_libcurl=TRUE,curl"
+PACKAGECONFIG[systemd] = ",-DCMAKE_DISABLE_FIND_PACKAGE_systemd=TRUE,systemd"
+
+BBCLASSEXTEND = "nativesdk"
+