dunfell: fix up inherits for python3

Most of these recipes are no longer needed but bitbake still verifies
the inherit clauses for them. python2 has been removed so need these to
all use the corresponding python3 classes.

(From meta-phosphor rev: d55b42ae26bf5198efeb38db9eed8166139408bd)

Change-Id: Idf5fee957d8d0f3128a766a8007c3053fc1464d9
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass b/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass
index 16dbc58..e691263 100644
--- a/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-py-daemon.bbclass
@@ -3,7 +3,7 @@
 inherit allarch
 inherit obmc-phosphor-systemd
 
-RDEPENDS_${PN} += "python-dbus python-pygobject"
+RDEPENDS_${PN} += "python3-dbus python3-pygobject"
 INSTALL_NAME ?= "${PN}"
 SCRIPT_NAME ?= "${INSTALL_NAME}.py"