meta-openembedded: subtree update:41fe46157c..e6d76b05a7
Adrian Bunk (1):
networkmanager: Correct the upstream version check
Adrian Ratiu (1):
renderdoc: add new recipe
Changqing Li (1):
kea: upgrade 1.5.0 -> 1.7.0
Denys Dmytriyenko (1):
rwmem: add recipe
Hongxu Jia (1):
lvm2: fix run lvcreate hung while PACKAGECONFIG udev
Jackie Huang (6):
python-versiontools: add recipes for python2 and python3
python-pymysql: add recipes for python2 and python3
python-statistics: add new recipe
python-pyperf: add recipes for python2 and python3
python-pika: add recipes for python2 and python3
python-pycurl: add recipes for python2 and python3
Khem Raj (6):
openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl
ttf-gentium: Use OFL-1.0 version of OFL license
ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file
python-configparser: Mark license as MIT
fontforge: Upgrade to 20190801 release
opensaf: Fix duplicate copies of shared libs in package
Martin Jansa (2):
spice: ignore all warnings not just address-of-packed-member
Revert "spice: Drop broken native"
Otavio Salvador (5):
networkmanager: Fix ADSL plugin packaging
networkmanager: Add a `resolvconf` PACKAGECONFIG
networkmanager: Add sysvinit support
libqmi: Upgrade 1.22.2 -> 1.24.0
modemmanager: Upgrade 1.10.0 -> 1.10.2
Qi.Chen@windriver.com (1):
protobuf-c: fix race condition
Robert Yang (2):
corosync: Fix PACKAGECONFIG flag for rdma
net-snmp: Fix PACKAGECONFIG for perl
Zang Ruochen (1):
python-urllib3: upgrade 1.25.5 -> 1.25.6
Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb b/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
index 3df6824..efa2bf5 100644
--- a/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
+++ b/meta-openembedded/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
@@ -25,6 +25,7 @@
file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
file://0001-Add-configure-time-check-for-gettid-API.patch \
+ file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \
"
SRC_URI[md5sum] = "e9ae9de803a99b7ab33757a49858542f"
SRC_URI[sha256sum] = "caed672d03ab1fe3f27d333429c7ca03022714e7c6350500208b7bd7349f03ce"
@@ -44,13 +45,11 @@
PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
-PKGLIBDIR="${libdir}"
CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
do_install_append() {
- cp -av --no-preserve=ownership ${B}/lib/.libs/*.so* ${D}${libdir}
rm -fr "${D}${localstatedir}/lock"
rm -fr "${D}${localstatedir}/run"
rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
@@ -61,7 +60,8 @@
fi
}
-FILES_${PN} += "${systemd_unitdir}/system/*.service"
+FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
+FILES_${PN}-dev += "${libdir}/libopensaf_core.so"
FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
INSANE_SKIP_${PN} = "dev-so"
@@ -70,3 +70,5 @@
# http://errors.yoctoproject.org/Errors/Details/186970/
COMPATIBLE_HOST_libc-musl = 'null'
+
+FILES_SOLIBSDEV = ""