meta-openembedded: subtree update:41fe46157c..e6d76b05a7
Adrian Bunk (1):
networkmanager: Correct the upstream version check
Adrian Ratiu (1):
renderdoc: add new recipe
Changqing Li (1):
kea: upgrade 1.5.0 -> 1.7.0
Denys Dmytriyenko (1):
rwmem: add recipe
Hongxu Jia (1):
lvm2: fix run lvcreate hung while PACKAGECONFIG udev
Jackie Huang (6):
python-versiontools: add recipes for python2 and python3
python-pymysql: add recipes for python2 and python3
python-statistics: add new recipe
python-pyperf: add recipes for python2 and python3
python-pika: add recipes for python2 and python3
python-pycurl: add recipes for python2 and python3
Khem Raj (6):
openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl
ttf-gentium: Use OFL-1.0 version of OFL license
ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file
python-configparser: Mark license as MIT
fontforge: Upgrade to 20190801 release
opensaf: Fix duplicate copies of shared libs in package
Martin Jansa (2):
spice: ignore all warnings not just address-of-packed-member
Revert "spice: Drop broken native"
Otavio Salvador (5):
networkmanager: Fix ADSL plugin packaging
networkmanager: Add a `resolvconf` PACKAGECONFIG
networkmanager: Add sysvinit support
libqmi: Upgrade 1.22.2 -> 1.24.0
modemmanager: Upgrade 1.10.0 -> 1.10.2
Qi.Chen@windriver.com (1):
protobuf-c: fix race condition
Robert Yang (2):
corosync: Fix PACKAGECONFIG flag for rdma
net-snmp: Fix PACKAGECONFIG for perl
Zang Ruochen (1):
python-urllib3: upgrade 1.25.5 -> 1.25.6
Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.24.0.bb b/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.24.0.bb
new file mode 100644
index 0000000..9b89e1d
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.24.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "libqmi is a library for talking to WWAN devices by QMI protocol"
+DESCRIPTION = "libqmi is a glib-based library for talking to WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol"
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libqmi"
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+"
+
+DEPENDS = "glib-2.0 glib-2.0-native"
+
+inherit autotools pkgconfig bash-completion
+
+SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz \
+ "
+
+SRC_URI[md5sum] = "4b181c0a8b933226ce3dce09565fe8f8"
+SRC_URI[sha256sum] = "aeb69f90c273467cce246176cba0967c6413f1995a976992770a597c4fe28c79"
+
+PACKAGECONFIG ??= "udev mbim"
+PACKAGECONFIG[udev] = ",--without-udev,libgudev"
+PACKAGECONFIG[mbim] = "--enable-mbim-qmux,--disable-mbim-qmux,libmbim"
+
+EXTRA_OECONF_append_toolchain-clang = " --enable-more-warnings=no"