meta-openembedded: subtree update:41fe46157c..e6d76b05a7
Adrian Bunk (1):
networkmanager: Correct the upstream version check
Adrian Ratiu (1):
renderdoc: add new recipe
Changqing Li (1):
kea: upgrade 1.5.0 -> 1.7.0
Denys Dmytriyenko (1):
rwmem: add recipe
Hongxu Jia (1):
lvm2: fix run lvcreate hung while PACKAGECONFIG udev
Jackie Huang (6):
python-versiontools: add recipes for python2 and python3
python-pymysql: add recipes for python2 and python3
python-statistics: add new recipe
python-pyperf: add recipes for python2 and python3
python-pika: add recipes for python2 and python3
python-pycurl: add recipes for python2 and python3
Khem Raj (6):
openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl
ttf-gentium: Use OFL-1.0 version of OFL license
ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file
python-configparser: Mark license as MIT
fontforge: Upgrade to 20190801 release
opensaf: Fix duplicate copies of shared libs in package
Martin Jansa (2):
spice: ignore all warnings not just address-of-packed-member
Revert "spice: Drop broken native"
Otavio Salvador (5):
networkmanager: Fix ADSL plugin packaging
networkmanager: Add a `resolvconf` PACKAGECONFIG
networkmanager: Add sysvinit support
libqmi: Upgrade 1.22.2 -> 1.24.0
modemmanager: Upgrade 1.10.0 -> 1.10.2
Qi.Chen@windriver.com (1):
protobuf-c: fix race condition
Robert Yang (2):
corosync: Fix PACKAGECONFIG flag for rdma
net-snmp: Fix PACKAGECONFIG for perl
Zang Ruochen (1):
python-urllib3: upgrade 1.25.5 -> 1.25.6
Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb b/meta-openembedded/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
new file mode 100644
index 0000000..b6e0c92
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
@@ -0,0 +1,35 @@
+SUMMARY = "RenderDoc recipe providing renderdoccmd"
+DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
+HOMEPAGE = "https://github.com/baldurk/renderdoc"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9753b1b4fba3261c27d1ce5c1acef667"
+
+SRCREV = "214d85228538e71cc63a0d7fa11dd75b1d56cc81"
+SRC_URI = "git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
+ file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
+"
+S = "${WORKDIR}/git"
+
+DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
+
+RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
+
+inherit cmake python3native
+
+python __anonymous () {
+ # only works on glibc systems
+ if d.getVar('TCLIBC') != "glibc":
+ raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
+}
+
+COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
+
+EXTRA_OECMAKE += "\
+ -DENABLE_QRENDERDOC=OFF \
+ -DENABLE_PYRENDERDOC=OFF \
+ -DENABLE_RENDERDOCCMD=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+"
+
+FILES_${PN} += "${libdir}"
+FILES_${PN}-dev = "${includedir}"