Fix dbus.Byte JSON encoding
dbus.Byte is not encoded by the JSON library in Python2.7
correctly. There was a hack added to dbus-python to
work around this.
Backport the JSON library fix from Python 3.x back to
Python2.7, so we can drop the hack from dbus-python.
Tested: verified encoding of dbus.Byte unchanged
Change-Id: Ifc8e0d22a25f4dd52da5a136809df25771684438
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-devtools/python/python_2.%.bbappend b/meta-phosphor/common/recipes-devtools/python/python_2.%.bbappend
index 569e753..e591a95 100644
--- a/meta-phosphor/common/recipes-devtools/python/python_2.%.bbappend
+++ b/meta-phosphor/common/recipes-devtools/python/python_2.%.bbappend
@@ -1,5 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://__init__.email_min.py"
+SRC_URI += "file://0001-json-Use-int-long.__str__-to-convert-subclasses.patch"
do_install_append_class-target() {
dir=${libdir}/python${PYTHON_MAJMIN}/email