Change wants to requires for all critical services

In order for targets to fail when their services fail,
the relationship must be a "requires"

Change-Id: I1523dd51af8817b473557bac65e9e71eacecf52e
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
index 3f7bf2b..16d24c7 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
@@ -25,7 +25,7 @@
 TMPL = "start_host@.service"
 INSTFMT = "start_host@{0}.service"
 TGTFMT = "obmc-chassis-start@{0}.target"
-FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
+FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
 
 SYSTEMD_SERVICE_${PN} += "${TMPL}"
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"