meta-raspberrypi: subtree update:f5fe02c30c..853ccd7440
Chris Laplante (8):
python3-adafruit-blinka: add recipe
python3-adafruit-circuitpython-busdevice: add recipe
python3-adafruit-circuitpython-motor: add recipe
python3-adafruit-circuitpython-motorkit: add recipe
python3-adafruit-circuitpython-pca9685: add recipe
python3-adafruit-circuitpython-register: add recipe
python3-adafruit-platformdetect: add recipe
python3-adafruit-pureio: add recipe
Jose Quaresma (3):
gstreamer1.0-omx: drop custom cflags
gstreamer1.0-omx: consolidate the append usage and only use one
gstreamer1.0-omx: drop config-files-path.patch
Khem Raj (2):
python3-adafruit-blinka: Make rpi-gpio dependency conditional
python3-adafruit-blinka: Delete microcontroller/bcm283x for non arm32 machines
Martin Jansa (2):
sdcard_image-rpi.bbclass: increase default boot partition size from 40MiB to 48MiB
sdcard_image-rpi.bbclass: shorten the default BOOTDD_VOLUME_ID
Mike Looijmans (1):
overlays: Add "vc4-kms-dsi-7inch.dtbo"
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: If81a2227cc45daf24cd0b2466651658bb1b71eb0
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
new file mode 100644
index 0000000..7d3120f
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
@@ -0,0 +1,30 @@
+SUMMARY = "CircuitPython APIs for non-CircuitPython versions of Python such as CPython on Linux and MicroPython."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Blinka"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=660e614bc7efb0697cc793d8a22a55c2"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Blinka.git"
+SRCREV = "dc688f354fe779c9267c208b99f310af87e79272"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+do_install_append() {
+# it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt
+# 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only
+ if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then
+ rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/adafruit_blinka/microcontroller/bcm283x
+ fi
+}
+
+RDEPENDS_${PN} += " \
+ libgpiod \
+ python3-adafruit-platformdetect \
+ python3-adafruit-pureio \
+ python3-core \
+"
+
+RDEPENDS_${PN}_append_rpi = " rpi-gpio"