meta-raspberrypi: subtree update:f5fe02c30c..853ccd7440
Chris Laplante (8):
python3-adafruit-blinka: add recipe
python3-adafruit-circuitpython-busdevice: add recipe
python3-adafruit-circuitpython-motor: add recipe
python3-adafruit-circuitpython-motorkit: add recipe
python3-adafruit-circuitpython-pca9685: add recipe
python3-adafruit-circuitpython-register: add recipe
python3-adafruit-platformdetect: add recipe
python3-adafruit-pureio: add recipe
Jose Quaresma (3):
gstreamer1.0-omx: drop custom cflags
gstreamer1.0-omx: consolidate the append usage and only use one
gstreamer1.0-omx: drop config-files-path.patch
Khem Raj (2):
python3-adafruit-blinka: Make rpi-gpio dependency conditional
python3-adafruit-blinka: Delete microcontroller/bcm283x for non arm32 machines
Martin Jansa (2):
sdcard_image-rpi.bbclass: increase default boot partition size from 40MiB to 48MiB
sdcard_image-rpi.bbclass: shorten the default BOOTDD_VOLUME_ID
Mike Looijmans (1):
overlays: Add "vc4-kms-dsi-7inch.dtbo"
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: If81a2227cc45daf24cd0b2466651658bb1b71eb0
diff --git a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
index a7aa8d9..a971236 100644
--- a/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
+++ b/meta-raspberrypi/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
@@ -1,8 +1,12 @@
+FILESEXTRAPATHS_prepend_rpi := "${THISDIR}/${PN}:"
+
+SRC_URI_append_rpi = " \
+ file://0001-Don-t-try-to-acquire-buffer-when-src-pad-isn-t-activ.patch \
+ file://0003-no-timeout-on-get-state.patch \
+ file://0004-Properly-handle-drain-requests-while-flushing.patch \
+ file://0005-Don-t-abort-gst_omx_video_dec_set_format-if-there-s-.patch \
+"
+
GSTREAMER_1_0_OMX_TARGET_rpi = "rpi"
GSTREAMER_1_0_OMX_CORE_NAME_rpi = "${libdir}/libopenmaxil.so"
-EXTRA_OEMESON_append_rpi = " -Dheader_path=${STAGING_DIR_TARGET}/usr/include"
-CFLAGS_append_rpi = " \
- -I${STAGING_DIR_TARGET}/usr/include/IL \
- -I${STAGING_DIR_TARGET}/usr/include/interface/vcos/pthreads \
- -I${STAGING_DIR_TARGET}/usr/include/interface/vmcs_host/linux \
-"
+EXTRA_OEMESON_append_rpi = " -Dheader_path=${STAGING_DIR_TARGET}/usr/include/IL"