gpioplus: Add library

Tested:
    Package builds successfully and the output looks correct.

(From meta-phosphor rev: cb1a1831baa36b0e6bb5e199a333255f42d3593e)

Change-Id: I6aa75e0147793b13992bd05ac9efffbaef19c092
Signed-off-by: William A. Kennington III <wak@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/common/recipes-extended/gpioplus/gpioplus_git.bb b/meta-phosphor/common/recipes-extended/gpioplus/gpioplus_git.bb
new file mode 100644
index 0000000..6fbc03c
--- /dev/null
+++ b/meta-phosphor/common/recipes-extended/gpioplus/gpioplus_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "C++ bindings for linux gpio APIs"
+DESCRIPTION = "C++ bindings for linux gpio APIs."
+HOMEPAGE = "http://github.com/openbmc/gpioplus"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+
+DEPENDS += " \
+        autoconf-archive-native \
+        "
+
+EXTRA_OECONF_append += " \
+        --disable-examples \
+        --disable-tests \
+        "
+
+SRC_URI += "git://github.com/openbmc/gpioplus"
+SRCREV = "68cce0fad1549f5144160182edd24bcdb83df6e0"
+
+S = "${WORKDIR}/git"