Add recipe for service-config-manager application
(From meta-phosphor rev: 5a1a1eddf685f8e3a101ff802f7d6725e3d96964)
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
Change-Id: I62145c146d1a181b178ab103dbcefb5a3fb57249
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/srvcfg-manager/srvcfg-manager_git.bb b/meta-phosphor/recipes-phosphor/srvcfg-manager/srvcfg-manager_git.bb
new file mode 100644
index 0000000..7b45d15
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/srvcfg-manager/srvcfg-manager_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Service configuration manager daemon to control the service"
+DESCRIPTION = "Applications must use service manager daemon to configure \
+ phosphor-ipmi-net, bmcweb, obmc-console etc in the system, \
+ instead of directly controlling the same using 'systemd' or \
+ 'iptables'."
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit meson pkgconfig systemd
+
+require srvcfg-manager.inc
+
+S = "${WORKDIR}/git"
+SYSTEMD_SERVICE_${PN} = "srvcfg-manager.service"
+
+DEPENDS += " \
+ boost \
+ phosphor-logging \
+ sdbusplus \
+ sdbusplus-native \
+ systemd \
+ "
\ No newline at end of file