subtree updates
meta-openembedded: 9a52bfc4a6..af11f6ce73:
Andreas Müller (4):
nautilus: Add a packageconfig for libportal - disabled by default
gtk4: upgrade 4.4.0 -> 4.6.2
libadwaita: initial add 1.1.0
gtksourceview5: upgrade 5.2.0 -> 5.4.0
Carlos Rafael Giani (3):
libopenmpt: Remove unnecessary python code block
pipewire: Upgrade to version 0.3.49
wireplumber: Upgrade to version 0.4.9
Kai Kang (4):
wxwidgets: 3.1.4 -> 3.1.5
python3-wxgtk4: add recipe
wxwidgets: fix typo
mcelog: fix compile error
Khem Raj (1):
python3-wxgtk4: Use cross prefix with native wx-config
Matthias Klein (1):
paho-mqtt-c: upgrade 1.3.9 -> 1.3.10
Mingli Yu (1):
mariadb: increase MY_AES_CTX_SIZE
Potin Lai (4):
libimobiledevice-glue: add recipe
libimobiledevice-glue: fix undefined bswap error
libirecovery: add recipe
idevicerestore: add recipe
S. Lockwood-Childs (1):
python3-evdev: fix host header contamination
Yi Zhao (2):
strongswan: 5.9.4 -> 5.9.5
libnetfilter-conntrack: upgrade 1.0.8 -> 1.0.9
meta-raspberrypi: c06ae5eacf..31c33d155c:
Khem Raj (3):
linux-raspberrypi_5.15.bb: Upgrade to 5.15.32
raspberrypi-firmware: Update to match 5.15.32
armstubs: Upgrade to 20211101
poky: 5fe3689f4f..1976521190:
Chen Qi (1):
gobject-introspection: fix default search path for girdir
Daniel Ammann (2):
overview-manual: Fix reference
ref-manual: Add vfat in list of filesystems supported by kickstart
Jagadeesh Krishnanjanappa (1):
cmake: support to create per-toolchain cmake file in SDK
Khem Raj (2):
weston: Add a knob to control simple clients
meson: Robustify compiler detection logic
Marta Rybczynska (1):
doc: migration-3.5: extend the section on inclusive language
Michael Halstead (1):
releases: update to include 3.4.3
Michael Opdenacker (4):
overview-manual: add missing upper case
docs: add poky.yaml and sphinx-static/switchers.js to "make clean"
manuals: fix quoting of double dashes
migration-guides: preliminary description for 3.5
Oleksandr Kravchuk (1):
python3: update to 3.10.4
Peter Kjellerstedt (1):
ref-manual: Remove references to AVAILABLE_LICENSES
Rasmus Villemoes (1):
git: make expat and curl into PACKAGECONFIG items
Richard Purdie (11):
set_versions/switchers: Drop versions shown to the active releases
mirrors: Add missing gitsm entries for yocto/oe mirrors
base: Don't add duplicates to sys.path
base: Clean up module import compatibility code
modutils-initscripts: Change license PD -> MIT
keymaps: Clean up license handling
initscripts: Clean up license handling/identifiers
bitbake: cooker: Further fixes to inotify to fix memres bitbake issues
bitbake: cooker: Restore sys.path and sys.modules between parses
bitbake: cooker: Ensure any existing hashserv connection is closed
bitbake: cooker: Avoid error if siggen wasn't setup
Ross Burton (24):
ref-manual: update Python class documentation
buildtools-tarball: include nativesdk-python3-pyyaml
image_types: hddimg and iso only work on x86
oeqa/selftest/devtool: ensure Git username is set before upgrade tests
oeqa/selftest/wic: use os.rename instead of bb.utils.rename
oeqa/selftest/wic: remove redundant asserts
oeqa/selftest/wic: clean up only_for_arch decorator
oeqa/selftest/wic: don't hardcode kernel image type in test_wic_rm
oeqa/selftest/wic: add more arch-specific annotations
oeqa/selftest/buildoptions: set PACKAGE_CLASSES in test_arch_work_dir_and_export_source
oeqa/runtime/decorator/package.py: remove use of strToSet
oeqa/core/decorator: remove redundant code
testimage: inline updateTestData()
oeqa/core/utils/misc: remove redundant file
oeqa/selftest: remove unused imports
oeqa/core/decorators/data: improve has_* logic
oeqa/selftest: tag tests that use runqemu
oeqa: rationalise skipifqemu decorators
oeqa/selftest/oescripts: refactor skipping logic
oeqa/selftest/wic: cleanup WicTestCase.setUpLocal
oeqa/selftest/wic: rearrange tests
oeqa/selftest/wic: use os.path.join to join paths
oeqa/selftest/wic: use self.td instead of get_bb_var to save on bitbake calls
oeqa/selftest: generalise test_devtool_virtual_kernel_modify
Simon Kuhnle (1):
convert-variable-renames: Fix typo in description
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ic8359fe5772351a45a3154c6a7f5042a88ff934c
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
index 97a8aed..ca324c9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
@@ -11,7 +11,7 @@
rm -rf ${S}/evdev/ecodes.c
}
-DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
+SETUPTOOLS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
RDEPENDS:${PN} += "\
${PYTHON_PN}-ctypes \