meta-amd: prep for amd meta layer refactoring

Code refactoring to support CRB's bring-up.

Configuration files "nohost" and "withhost" variants
introduced to support various stages of  bring-up in
AMD CRBs.

Change-Id: Id52ac68edf365e6623bd71992fdd6d9fc8a3adf5
Signed-off-by: Jayanth Othayoth <ojayanth@gmail.com>
diff --git a/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb b/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb
index a3a74b7..43a0be0 100644
--- a/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb
+++ b/meta-amd/recipes-amd/packagegroups/packagegroup-amd-apps.bb
@@ -5,11 +5,14 @@
 
 PROVIDES = "${PACKAGES}"
 PACKAGES = " \
-        ${PN}-chassis \
         ${PN}-fans \
         ${PN}-flash \
         ${PN}-system \
         "
+PACKAGES:append:amd-withhost = " \
+        ${PN}-chassis \
+        ${PN}-hostmgmt \
+        "
 
 PROVIDES += "virtual/obmc-chassis-mgmt"
 PROVIDES += "virtual/obmc-fan-mgmt"
@@ -39,10 +42,14 @@
 
 SUMMARY:${PN}-system = "AMD System"
 RDEPENDS:${PN}-system = " \
-        amd-fpga \
         dbus-sensors \
         entity-manager \
         ipmitool \
-        phosphor-hostlogger \
         srvcfg-manager \
+        ${RDEPENDS_PN_SYSTEM_EXTRAS} \
+        "
+RDEPENDS_PN_SYSTEM_EXTRAS = ""
+RDEPENDS_PN_SYSTEM_EXTRAS:amd-withhost = " \
+        amd-fpga \
+        phosphor-hostlogger \
         "