meta-ibm: system1: enable and configure ipmi-fru

Utilize the ipmi-fru features to read the MAC address from the board VPD
and populate on d-bus for the networking code.

Tested:
- Confirmed MAC addresses were read from the seeprom and put on d-bus

Change-Id: Ia292b10b80539376639b444c44a49285cadff4c1
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/meta-system1/recipes-phosphor/configurations/system1-yaml-config.bb b/meta-ibm/meta-system1/recipes-phosphor/configurations/system1-yaml-config.bb
new file mode 100644
index 0000000..6e091dc
--- /dev/null
+++ b/meta-ibm/meta-system1/recipes-phosphor/configurations/system1-yaml-config.bb
@@ -0,0 +1,27 @@
+SUMMARY = "YAML configuration for IBM System1"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+
+SRC_URI = " \
+    file://system1-ipmi-fru.yaml \
+    file://system1-ipmi-fru-properties.yaml \
+    "
+
+S = "${WORKDIR}"
+
+do_install() {
+    install -m 0644 -D system1-ipmi-fru.yaml \
+        ${D}${datadir}/${BPN}/ipmi-fru-read.yaml
+    install -m 0644 -D system1-ipmi-fru-properties.yaml \
+        ${D}${datadir}/${BPN}/ipmi-extra-properties.yaml
+}
+
+FILES:${PN}-dev = " \
+    ${datadir}/${BPN}/ipmi-fru-read.yaml \
+    ${datadir}/${BPN}/ipmi-extra-properties.yaml \
+    "
+
+ALLOW_EMPTY:${PN} = "1"