Remove obmc-openpower-* machine features

The openpower layer supports a usage pattern of building non
openpower systems with the openpower layer included in the layer
configuration (introduced with 008b81bb).

As a part of 008b81bb a number of distro and machine features
were added.  As with MRW and UBI before it, these features
are distro policy and not machine features.  As such remove the
machine features.

Additionally converge the three feature variants down to a single
openpower feature since there aren't any in-tree systems that don't
enable all three.

Add a distro override and fix up combined feature checks to use
this override instead for improved readability.

Add a new distro configuration that enables these features and
point all Openpower sample local.conf files to this new distro
config.

Tested: Built and validated Witherspoon, Palmetto images
Change-Id: Ifa3df61fbe1803f00c38956c265604ba91d7d127
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index e0e13aa..7eb88fb 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1,24 +1,24 @@
-RDEPENDS_${PN}-extrasdevtools_append = " ${@cf_enabled(d, 'obmc-openpower', 'obmc-pydevtools')}"
+RDEPENDS_${PN}-extrasdevtools_append_df-openpower = " obmc-pydevtools"
 
 # Add the deprecated /org/openbmc inventory namespace providing
 # obmc-mgr-inventory application to the inventory packagegroup
 # until all applications have been updated to use the new,
 # officially spec'ed xyz.openbmc_project.Inventory.Manager
 # provider (VIRTUAL-RUNTIME_obmc-inventory-manager).
-RDEPENDS_${PN}-inventory_append = " ${@cf_enabled(d, 'obmc-openpower-legacy', 'obmc-mgr-inventory')}"
+RDEPENDS_${PN}-inventory_append_df-openpower = " obmc-mgr-inventory"
 
 # Add the deprecated /org/openbmc sensor namespace providing
 # the obmc-mgr-sensor application to the sensor
 # packagegroup until all applications have been updated to use
 # the new, officially spec'ed xyz.openbmc_project.SensorValue
 # providers (VIRTUAL-RUNTIME_obmc-sensor-hwmon).
-RDEPENDS_${PN}-sensors_append = " ${@cf_enabled(d, 'obmc-openpower-legacy', 'obmc-mgr-sensor')}"
+RDEPENDS_${PN}-sensors_append_df-openpower = " obmc-mgr-sensor"
 
 # Add checkstop monitor as part of host state management package
 # This will kick start a gpio monitor that will catch the
 # host checkstop conditions and takes necessary actions
-RDEPENDS_${PN}-host-state-mgmt_append = " ${@cf_enabled(d, 'obmc-openpower', 'checkstop-monitor')}"
+RDEPENDS_${PN}-host-state-mgmt_append_df-openpower = " checkstop-monitor"
 
 # Add openpower debug collector as a requirement for state-mgmt
 # since it is used during checkstop handling.
-RDEPENDS_${PN}-host-state-mgmt_append = " ${@cf_enabled(d, 'obmc-openpower', 'openpower-debug-collector')}"
+RDEPENDS_${PN}-host-state-mgmt_append_df-openpower = " openpower-debug-collector"