kernel: FSI, hwmon, LED GPIO and device tree fixes

Andrew Jeffery (2):
      hwmon: max31785: Clean up uninitialised values
      hwmon: max31785: Use standard sysfs ABI for fast rotor inputs

Cédric Le Goater (5):
      leds: pca955x: add device tree support
      leds: pca955x: use devm_led_classdev_register
      leds: pca955x: add GPIO support
      dt-bindings leds: add pca955x
      ARM: dts: aspeed: witherspoon: Add pca9552 device

Edward A. James (7):
      fsi: occ: Fix 1 byte response and rc for O_NONBLOCK
      hwmon: occ: Add new sensor versions and non-hwmon attributes
      hwmon: occ: Add P8 OCC access
      occ: hwmon and fsi probing fix
      ARM: aspeed: Power9 dts and defconfigs for OCC
      drivers: fsi: sbefifo: Fix buffer initialization
      drivers: hwmon: occ: Add "master" attribute and remove status files

Joel Stanley (1):
      ARM: configs: aspeed: Add pca9552 driver

Rick Altherr (1):
      ARM: dts: aspeed: quanta-q71l: Add i2c and LED devices

Change-Id: I9d1307cd3d8e0eaa86197a2da858dd0d83174d6c
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.10.bb b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.10.bb
index 5b2cabd..f31f12b 100644
--- a/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.10.bb
+++ b/meta-phosphor/common/recipes-kernel/linux/linux-obmc_4.10.bb
@@ -1,6 +1,6 @@
 KBRANCH ?= "dev-4.10"
 LINUX_VERSION ?= "4.10.17"
 
-SRCREV="c694e47cbc1efc2bc181b2ac7137dfda04f974c2"
+SRCREV="09041b7c3b65a7ec1063d4882b58fd6f00fc87b3"
 
 require linux-obmc.inc