meta-ibm:Remove execution of set-all-groups-asserted

The commit removes dependecy of obmc-led-set-all-groups-asserted
from the recipe file of phosphor-led-manager.

The script executed by the service curently sets asserted property
of all the LED groups to false on BMC boot which is now being set
using operational status. Hence the script is no longer required.

Change-Id: I6ddfa17ec70d75f115931d78d5866dab8a7e1f21
Signed-off-by: Sunny Srivastava <sunnsr25@in.ibm.com>
diff --git a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
index b36adca..d927f25 100644
--- a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
@@ -1,6 +1,6 @@
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 
-SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-led-set-all-groups-asserted@.service obmc-led-create-virtual-leds@.service"
+SYSTEMD_SERVICE:${PN}:append:p10bmc = " obmc-led-create-virtual-leds@.service"
 
 # Copies config file having arguments for led-set-all-groups-asserted.sh
 SYSTEMD_ENVIRONMENT_FILE:${PN}:append:p10bmc =" obmc/led/set-all/groups/config"
@@ -17,18 +17,6 @@
 
     # Needed this to run as part of BMC boot
     mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
-    LINK="$D$systemd_system_unitdir/multi-user.target.wants/obmc-led-set-all-groups-asserted@false.service"
-    TARGET="../obmc-led-set-all-groups-asserted@.service"
-    ln -s $TARGET $LINK
-
-    # Needed this to run as part of Power On
-    mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants
-    LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/obmc-led-set-all-groups-asserted@false.service"
-    TARGET="../obmc-led-set-all-groups-asserted@.service"
-    ln -s $TARGET $LINK
-
-    # Needed this to run as part of BMC boot
-    mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
     LINK_FAULT="$D$systemd_system_unitdir/multi-user.target.wants/obmc-led-create-virtual-leds@sys-class-leds-virtual-enc-fault.service"
     TARGET_FAULT="../obmc-led-create-virtual-leds@.service"
     ln -s $TARGET_FAULT $LINK_FAULT
@@ -42,12 +30,6 @@
 
 pkg_prerm:${PN}:p10bmc () {
 
-    LINK="$D$systemd_system_unitdir/multi-user.target.wants/obmc-led-set-all-groups-asserted@false.service"
-    rm $LINK
-
-    LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/obmc-led-set-all-groups-asserted@false.service"
-    rm $LINK
-
     LINK_FAULT="$D$systemd_system_unitdir/multi-user.target.wants/obmc-led-create-virtual-leds@sys-class-leds-virtual-enc-fault.service"
     rm $LINK_FAULT