meta-lanyang: add IPMI recipe
Add CPU, DIMM and Motherboard inventory for Lanyang machine
Tested: Built the IPMI recipe then read the information of the CPU,
DIMM and Motherboard's inventory after power on.
(From meta-inventec rev: 9d47808f7e1a582a7001b11bb9419742b17d4a1c)
Change-Id: I0b550daa15bc9ab73948075e7cc1ac172612e88f
Signed-off-by: Brian Yang <yang.brianc.w@inventec.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-inventec/meta-lanyang/recipes-phosphor/ipmi/lanyang-ipmi-inventory-map-native.bb b/meta-inventec/meta-lanyang/recipes-phosphor/ipmi/lanyang-ipmi-inventory-map-native.bb
new file mode 100644
index 0000000..7a155c2
--- /dev/null
+++ b/meta-inventec/meta-lanyang/recipes-phosphor/ipmi/lanyang-ipmi-inventory-map-native.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Lanyang IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+