meta-facebook: console: Add support for YV3.5 platform.
Added obmc-console multi host support for yosemiteV3.5 platform.
Tested : Verified this on Yosemite V3.5 platform by launching all 4
server instance and verified SoL output from hosts.
Signed-off-by: Kumar Thangavel <thangavel.k@hcl.com>
Change-Id: Iefca7af84e2f442575e29f0634d2d7e6612686d3
diff --git a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
index 2666140..05b4a4e 100644
--- a/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-facebook/recipes-phosphor/console/obmc-console_%.bbappend
@@ -1,20 +1,21 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
OBMC_CONSOLE_HOST_TTY = "ttyS2"
-SRC_URI:append:tiogapass = " file://server.ttyS2.conf"
-SRC_URI:append:yosemitev2 = " file://server.ttyS0.conf \
- file://server.ttyS1.conf \
- file://server.ttyS2.conf \
- file://server.ttyS3.conf \
- file://client.2200.conf \
- file://client.2201.conf \
- file://client.2202.conf \
- file://client.2203.conf"
+SRC_URI:append:fb-compute-singlehost = " file://server.ttyS2.conf"
+
+SRC_URI:append:fb-compute-multihost = " file://server.ttyS0.conf \
+ file://server.ttyS1.conf \
+ file://server.ttyS2.conf \
+ file://server.ttyS3.conf \
+ file://client.2200.conf \
+ file://client.2201.conf \
+ file://client.2202.conf \
+ file://client.2203.conf"
SRC_URI:remove = "file://${BPN}.conf"
-SYSTEMD_SERVICE:${PN}:remove:yosemitev2 = "obmc-console-ssh.socket"
-EXTRA_OECONF:append:yosemitev2 = " --enable-concurrent-servers"
+SYSTEMD_SERVICE:${PN}:remove:fb-compute-multihost = "obmc-console-ssh.socket"
+EXTRA_OECONF:append:fb-compute-multihost = " --enable-concurrent-servers"
do_install:append() {
# Install the server configuration