meta-phosphor: Use '=' with append
Yocto has started throwing WARNINGs about using 'append' with '+=':
WARNING: ...:append += is not a recommended operator combination, please replace it.
This changes the '+=' in those cases to '=' and adds a leading
space when needed.
Tested: confirmed that it builds without these warnings
Signed-off-by: Jason M. Bills <jason.m.bills@intel.com>
Change-Id: I970e06ca6f9d0a9792af122eb25da1bb9a06f058
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
index 5d0da58..18cb48e 100644
--- a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
+++ b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
@@ -2,7 +2,7 @@
SRC_URI += "file://avahi-daemon-override.conf"
-FILES:avahi-daemon:append += "${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
+FILES:avahi-daemon:append = " ${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
do_install:append() {