meta-phosphor: Use '=' with append

Yocto has started throwing WARNINGs about using 'append' with '+=':

WARNING: ...:append += is not a recommended operator combination, please replace it.

This changes the '+=' in those cases to '=' and adds a leading
space when needed.

Tested: confirmed that it builds without these warnings

Signed-off-by: Jason M. Bills <jason.m.bills@intel.com>
Change-Id: I970e06ca6f9d0a9792af122eb25da1bb9a06f058
diff --git a/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend b/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
index f4f3b42..e921c80 100644
--- a/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
+++ b/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
@@ -1,6 +1,6 @@
-EXTRA_OECONF:append:class-target += " --disable-largefile --disable-locale \
-                                      --disable-iconv --without-included-popt \
-                                      --without-included-zlib"
+EXTRA_OECONF:append:class-target = " --disable-largefile --disable-locale \
+                                     --disable-iconv --without-included-popt \
+                                     --without-included-zlib"
 
 PACKAGECONFIG = ""