meta-google: nanopb: Update from 0.4.5 -> 0.4.8
This is intended to fix some build issues with the old 0.4.5 package and
splits the generator bits out from the runtime bits. The change was
taken from meta-openembedded@341c47848d04a2114b8c794ef6e01b03c80c801a
and these files will eventually be deleted.
Change-Id: If9e5886ff584305da9057a9de79e15fe288843fb
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-google/nanopb/nanopb-runtime_0.4.8.bb b/meta-google/recipes-google/nanopb/nanopb-runtime_0.4.8.bb
new file mode 100644
index 0000000..e43931a
--- /dev/null
+++ b/meta-google/recipes-google/nanopb/nanopb-runtime_0.4.8.bb
@@ -0,0 +1,17 @@
+require nanopb.inc
+
+EXTRA_OECMAKE += " \
+ -Dnanopb_PROTOC_PATH=/bin/false \
+ -DBUILD_SHARED_LIBS=ON \
+ -Dnanopb_BUILD_RUNTIME=ON \
+ -Dnanopb_BUILD_GENERATOR=OFF \
+ "
+
+# Maintain compatability with old header locations for packages
+# which haven't yet migrated to `nanopb/pb*.h`
+do_install:append() {
+ for hdr in ${D}${includedir}/nanopb/*; do
+ ln -sv nanopb/$(basename "$hdr") ${D}${includedir}/
+ done
+}
+