meta-phosphor: cmake packages: add pkgconfig

With the latest Yocto we see failures:

```
17:14:36 | CMake Error at /home/jenkins-op/workspace/ci-openbmc/distro/ubuntu/label/docker-builder/target/tiogapass/build/work/arm1176jzs-openbmc-linux-gnueabi/phosphor-ipmi-ipmb/0.1+gitAUTOINC+8227626764-r0/recipe-sysroot-native/usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
17:14:36 |   Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
```

Add the correct inherit for ipmb-ipmb.  Pre-emptively add for any
recipe which does 'inherit cmake'.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ib3327af0f19268d1f5b70259c3445b0985da9fa0
diff --git a/meta-phosphor/recipes-support/cjson/cjson_git.bb b/meta-phosphor/recipes-support/cjson/cjson_git.bb
index 1b83dd1..67512ff 100644
--- a/meta-phosphor/recipes-support/cjson/cjson_git.bb
+++ b/meta-phosphor/recipes-support/cjson/cjson_git.bb
@@ -8,7 +8,7 @@
 
 S = "${WORKDIR}/git"
 
-inherit cmake
+inherit cmake pkgconfig
 
 FILES:${PN}-dev += "${libdir}/cmake/cJSON/*"