meta-phosphor: cmake packages: add pkgconfig

With the latest Yocto we see failures:

```
17:14:36 | CMake Error at /home/jenkins-op/workspace/ci-openbmc/distro/ubuntu/label/docker-builder/target/tiogapass/build/work/arm1176jzs-openbmc-linux-gnueabi/phosphor-ipmi-ipmb/0.1+gitAUTOINC+8227626764-r0/recipe-sysroot-native/usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
17:14:36 |   Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
```

Add the correct inherit for ipmb-ipmb.  Pre-emptively add for any
recipe which does 'inherit cmake'.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ib3327af0f19268d1f5b70259c3445b0985da9fa0
diff --git a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
index cf1d6b1..b7bad6e 100644
--- a/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
+++ b/meta-phosphor/recipes-x86/peci-pcie/peci-pcie_git.bb
@@ -4,7 +4,7 @@
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
-inherit cmake systemd
+inherit cmake pkgconfig systemd
 
 SRC_URI = "git://github.com/openbmc/peci-pcie"