phosphor-power: split into separated packages

phosphor-power consists of several separated services and utils. All of
them are installed by default.

Split them into separated packages, so that a machine layer could select
which packages are needed.
This is done by define PACKAGE_BEFORE_PN and specify the FILES_ for each
package, and split the phosphor-power-systemd-links-monitor.bb into
separated recipes to install services for the related package.

The phosphor-power-systemd-links.bb is kept for now to avoid build error
on existing systems. It will be removed when the meta-system layers'
changes are done.

Tested: Only include phosphor-power-monitor, verify that only the
        related binary and service unit file are installed into the
        image.
        Include all the packages, verify that all the services and utils
        are installed into the image.

(From meta-phosphor rev: 2172cd128215683d1fd425b841e90b515aec04c9)

Signed-off-by: Lei YU <mine260309@gmail.com>
Change-Id: I83f436e51b33903a581bfc48541475711467bb61
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links.bb b/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links.bb
index 2baaf0d..f84ad28 100644
--- a/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links.bb
+++ b/meta-phosphor/recipes-phosphor/power/phosphor-power-systemd-links.bb
@@ -1,3 +1,7 @@
+# TODO: This is splitted into two recipes;
+#       To avoid build error, this is kept for now.
+#       Remove me when the refactor of phosphor-power recipe is finished
+
 SUMMARY = "Phosphor Power services installation"
 PR = "r1"
 
@@ -9,38 +13,3 @@
 RDEPENDS_${PN} += "phosphor-power"
 
 ALLOW_EMPTY_${PN} = "1"
-
-pkg_postinst_${PN}() {
-	mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants
-	mkdir -p $D$systemd_system_unitdir/multi-user.target.requires
-
-	LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
-	TARGET="../pseq-monitor.service"
-	ln -s $TARGET $LINK
-
-	LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
-	TARGET="../pseq-monitor-pgood.service"
-	ln -s $TARGET $LINK
-
-	[ -z "${OBMC_POWER_SUPPLY_INSTANCES}" ] && echo "No power supply instance defined" && exit 1
-
-	for inst in ${OBMC_POWER_SUPPLY_INSTANCES}; do
-		LINK="$D$systemd_system_unitdir/multi-user.target.requires/power-supply-monitor@$inst.service"
-		TARGET="../power-supply-monitor@.service"
-		ln -s $TARGET $LINK
-	done
-}
-
-pkg_prerm_${PN}() {
-	LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
-	rm $LINK
-	LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
-	rm $LINK
-
-	[ -z "${OBMC_POWER_SUPPLY_INSTANCES}" ] && echo "No power supply instance defined" && exit 1
-
-	for inst in ${OBMC_POWER_SUPPLY_INSTANCES}; do
-		LINK="$D$systemd_system_unitdir/multi-user.target.requires/power-supply-monitor@$inst.service"
-		rm $LINK
-	done
-}