Add Inventec's Transformers platform
Change-Id: Ic8aaa0728a43936cd4c6212d590e01ba8202b25b
Signed-off-by: Habeeb Mohammed <mohammed.habeeb@inventec.com>
diff --git a/meta-inventec/meta-transformers/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend b/meta-inventec/meta-transformers/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
new file mode 100644
index 0000000..405f9a5
--- /dev/null
+++ b/meta-inventec/meta-transformers/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${BPN}:"
+# In order to reuse and easily maintain, we use the same patch files among u-boot-aspeed-sdk
+FILESEXTRAPATHS:append := "${THISDIR}/u-boot-aspeed-sdk:"
+
+
+SRC_URI:append += "file://fw_env.config \
+ file://transformers-ast2600.cfg \
+ "
+
+do_install:append () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 0644 ${WORKDIR}/fw_env.config ${S}/tools/env/fw_env.config
+}
+