meta-ibm: introduce new huygens system
The huygens machine is based on the new pstbmc machine family from IBM.
It will be our first redundant BMC system [1].
The initial focus on this machine will be the redundant BMC feature.
The simulation model we use will just be 2 BMCs initially. Due to this
focus and simulation model, this commit strips out all of the host
firmware and host processor related features.
Tested:
- Confirmed in our 2 BMC simulation model that both BMCs come to Ready
and only the expected vpd services have failed
- Confirmed network into the BMCs worked as expected
[1]: https://gerrit.openbmc.org/c/openbmc/docs/+/70233
Change-Id: Ieb42337980c0ec39d16c492c77810473d5105aa0
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 745071f..0029ee7 100644
--- a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -1,6 +1,8 @@
OBMC_IMAGE_EXTRA_INSTALL:append:ibm-ac-server = " mboxd max31785-msl phosphor-msl-verify liberation-fonts uart-render-controller first-boot-set-hostname"
OBMC_IMAGE_EXTRA_INSTALL:remove:witherspoon-tacoma = " liberation-fonts uart-render-controller"
OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd"
+# No host firmware related features for huygens wanted yet
+OBMC_IMAGE_EXTRA_INSTALL:remove:huygens = " mboxd"
IMAGE_FEATURES:append = " obmc-dbus-monitor"