meta-openembedded: subtree update:466fd78ac6..41fe46157c
Callaghan, Dan (2):
firewalld: add UPSTREAM_CHECK_URI
add new recipes for python-lrparsing, python3-lrparsing
Khem Raj (2):
mongodb: Remove non building arches from COMPATIBLE_HOST
uim: Fix cross-builds
Martin Jansa (1):
libmicrohttpd: backport the fix for building with older gnutls
Oleksandr Kravchuk (4):
libyui: update to 3.6.0
libyui-ncurses: udpate to 2.52.0
sanlock: update to 3.6.0
tesseract-lang: update to 4.0.0
Randy MacLeod (1):
crash: update from 7.2.6 to 7.2.7
Robert Yang (8):
python-asn1crypto: extend to nativesdk
python-incremental: Drop broken nativesdk
fuse: Fix installed-vs-shipped for nativesdk
keyutils: Fix installed-vs-shipped for nativesdk
libnet-ssleay-perl: Drop broken native
libnet-dns-sec-perl: Drop broken native
iperf3: Drop broken native
spice: Drop broken native
Trevor Gamblin (1):
haveged: upgrade v1.9.4 -> v1.9.6
Zang Ruochen (5):
xterm: upgrade 348 -> 349
python-cmd2: upgrade 0.9.16 -> 0.9.17
python-protobuf: upgrade 3.9.1 -> 3.9.2
python-alembic: upgrade 1.2.0 -> 1.2.1
python-paste: upgrade 3.2.0 -> 3.2.1
Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-graphics/tesseract/tesseract-lang_4.0.0.bb b/meta-openembedded/meta-oe/recipes-graphics/tesseract/tesseract-lang_4.0.0.bb
new file mode 100644
index 0000000..75c2bc0
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/tesseract/tesseract-lang_4.0.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "tesseract-ocr language files"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9648bd7af63bd3cc4f5ac046d12c49e4"
+
+SRCREV = "590567f20dc044f6948a8e2c61afc714c360ad0e"
+SRC_URI = "git://github.com/tesseract-ocr/tessdata.git"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${datadir}/tessdata
+ cp -R --no-dereference --preserve=mode,links -v ${S}/*.traineddata ${D}${datadir}/tessdata
+}
+
+python populate_packages_prepend () {
+ tessdata_dir= d.expand('${datadir}/tessdata')
+ pkgs = do_split_packages(d, tessdata_dir, '^([a-z_]*)\.*', '${BPN}-%s', 'tesseract-ocr language files for %s', extra_depends='')
+ pn = d.getVar('PN')
+ d.appendVar('RDEPENDS_' + pn, ' '+' '.join(pkgs))
+}
+
+PACKAGES_DYNAMIC += "^${BPN}-.*"
+ALLOW_EMPTY_${PN} = "1"