meta-facebook: remove .sh suffix for scripts
Scripts and executables should not have a language-based extension
in order to simplify user operations and to avoid excessive refactoring
when rewrites are done. Remove all `.sh` extensions on scripts.
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I408fa0f31e6064c0ce3c1559a4182cd625e91f21
diff --git a/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend b/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend
index b97697d..077f1b4 100644
--- a/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend
+++ b/meta-facebook/meta-yosemite4/recipes-networking/mctp/mctp_%.bbappend
@@ -3,9 +3,9 @@
SRC_URI += " \
file://setup-local-eid.conf \
file://setup-static-endpoints.conf \
- file://mctp-config.sh \
- file://setup-static-endpoints.sh \
- file://nic-gpio-addrs.sh \
+ file://mctp-config \
+ file://setup-static-endpoints \
+ file://nic-gpio-addrs \
"
FILES:${PN} += "${systemd_system_unitdir}/*"
@@ -21,10 +21,10 @@
install -d ${D}${libexecdir}/mctp
- install -m 0755 ${WORKDIR}/mctp-config.sh \
+ install -m 0755 ${WORKDIR}/mctp-config \
${D}${libexecdir}/mctp/
- install -m 0755 ${WORKDIR}/setup-static-endpoints.sh \
+ install -m 0755 ${WORKDIR}/setup-static-endpoints \
${D}${libexecdir}/mctp/
- install -m 0755 ${WORKDIR}/nic-gpio-addrs.sh \
+ install -m 0755 ${WORKDIR}/nic-gpio-addrs \
${D}${libexecdir}/mctp/
}