obmc-console: Convert configs from socket-id to console-id
As of 9a8f30ec5b58 ("obmc-console: Introduce console-id, deprecate
socket-id") in obmc-console `console-id` is preferred over `socket-id`.
Convert all in-tree configurations to `console-id` to enable removal of
support for the deprecated `socket-id` configuration option.
Change-Id: Ifd50603c378cfed5eb793b829b8296b7964e4194
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
index b318c88..dbcb6ab 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
@@ -6,20 +6,20 @@
install_concurrent_console_config() {
# Install configuration for the servers and clients. Keep commandline
# compatibility with previous configurations by defaulting to not
- # specifying a socket-id for VUART0/2200
+ # specifying a console-id for VUART0/2200
install -m 0755 -d ${D}${sysconfdir}/${BPN}
# Remove the default client configuration as we don't to define a
- # socket-id for the 2200 console
+ # console-id for the 2200 console
rm -f ${D}${sysconfdir}/${BPN}/client.2200.conf
# However, now link to /dev/null as a way of not specifying a
- # socket-id while having a configuration file present. We need to
+ # console-id while having a configuration file present. We need to
# provide a configuration path to meet the requirements of the packaged
# unit file.
ln -sr ${D}/dev/null ${D}${sysconfdir}/${BPN}/client.2200.conf
- # We need to populate socket-id for remaining consoles
+ # We need to populate console-id for remaining consoles
install -m 0644 ${WORKDIR}/client.2201.conf ${D}${sysconfdir}/${BPN}/
# Install configuration for remaining servers - the base recipe