Add root user to required groups as per recipe

root user has to be added to groups accordingly based
on the recipe. i.e. phosphor-ipmi-host_git.bb, will create
both ipmi group, and add root user to the same.

Unit-test:
1. Verified root user is added to the groups accordingly.

(From meta-phosphor rev: 41882fbf717f267b280ab8ed3393f1178a029258)

Change-Id: I79d3a23fd939f38064999ebe99f17f3e0c02ed0c
Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index 40ec570..46dba14 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -6,6 +6,8 @@
 # add a user called httpd for the server to assume
 USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb"
 GROUPADD_PARAM_${PN} = "web; redfish"
+# Add root user to web & redfish group
+GROUPMEMS_PARAM_${PN} = "-g web -a root; -g redfish -a root"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"