meta-openembedded: subtree update:a2928764c2..19528ba2a6
Adrian Bunk (1):
libqmi: Replace clang patch with configure option
Bartosz Golaszewski (3):
yad: new package
zenity: new package
unclutter-xfixes: new package
Khem Raj (2):
mycroft: Remove alsa-oss from rdeps
bigbuckbunny: Use faster download mirrors
Oleksandr Kravchuk (21):
capnproto: update to 0.7.0
ddrescue: update to 1.24
fmt: update to 6.0.0
jsonrpc: update to 1.2.0
libburn: update to 1.5.0
libdvdread: update to 6.0.1
libev: update to 4.27
libmodplug: update to 0.8.9.0
libnice: update to 0.1.16
libopus: update to 1.3.1
libsass: update to 3.6.1
libuv: update to 1.32.0
libsocketcan: update to 0.0.11
tree: update to 1.8.0
xclock: update to 1.0.9
xcursorgen: update to 1.0.7
xfontsel: update to 1.0.6
xmag: update to 1.0.6
xmessage: update to 1.0.5
xorg-sgml-doctools: update to 1.11
evtest: update to 1.34
Peiran Hong (1):
tcpdump: Fix CVE-2017-16808
Change-Id: I4f2f575382cd34404d10470ece0aae7620487902
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb b/meta-openembedded/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb
new file mode 100644
index 0000000..b237757
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/jsonrpc/jsonrpc_1.2.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "C++ framework for json-rpc 1.0 and 2.0"
+DESCRIPTION = "JsonRpc-Cpp is an OpenSource implementation of JSON-RPC \
+ protocol in C++. JSON-RPC is a lightweight remote procedure \
+ call protocol similar to XML-RPC."
+HOMEPAGE = "https://github.com/cinemast/libjson-rpc-cpp"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e728c5b36018f6c383b4b9efd9c8840"
+SECTION = "libs"
+
+DEPENDS = "curl jsoncpp libmicrohttpd hiredis"
+
+SRC_URI = "git://github.com/cinemast/libjson-rpc-cpp"
+SRCREV = "4ed5b00dcc409405a19e6d8c6478f703153430e1"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DCOMPILE_TESTS=NO -DCOMPILE_STUBGEN=NO -DCOMPILE_EXAMPLES=NO \
+ -DBUILD_SHARED_LIBS=YES -DBUILD_STATIC_LIBS=YES \
+ -DCMAKE_LIBRARY_PATH=${libdir} \
+"
+
+FILES_${PN}-dev += "${libdir}/libjson-rpc-cpp/cmake"